101Level - Foro

[Ayuda] Problema con los lua y los lub al agregar custom item

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Angeluz

  • *
  • 13
  • 0
  • Actividad:
    10%
  • Sexo: Masculino
Hola comunidad, acudo a ustedes debido a la gran dificultad que me he visto, tratare de colocar toda la información necesaria para que me puedan ayudar :c

Problema: Intenté agregar item nuevos a mi servidor, pero resulta que no puedo observar los item custom como corresponde. No me arroja error ni nada, simplemente no se ven.

En este caso les mostrare todo lo necesario que utilice para implementar un solo item (Feather beret naranja)

Datos:
Emulador: rAthena (Oboro)
Exe: 2015-11-04aRagexe

Programas que utilizo:
Nemo Updated 2018-03-26 (para el exe)
Itemconverter (para crear el iteminfo.lua)
luac5.1.4 (para crear el accname.lub y el accesoryid.lub)

Grf

Dentro de la carpeta de texture/À¯ÀúÀÎÅÍÆäÀ̽º/item:


Dentro de la carpeta de texture/À¯ÀúÀÎÅÍÆäÀ̽º/collection:


Dentro de la carpeta de sprite/¾Ç¼¼»ç¸®/³²:


Dentro de la carpeta de sprite/¾Ç¼¼»ç¸®/¿©:



Archivos Lua
System/iteminfo.lua

lua files/datainfo/accname.lua

lua files/datainfo/accesoryid.lua


También copie los archivos accname.lub y accessoryid.lub pero me da error al entrar en el juego

Exe
Idview aumentada a 30000

Lee primero el iteminfo.lua que el iteminfo.lub


DB:


In-Game


Guias que consulte previamente:
https://foro.101level.com/eathena-guias-y-faqs/(guia)-agregar-custom-items-por-medio-de-lua/
https://foro.101level.com/(servidor)-guias-y-faq's/(faq)-agregar-item-custom-via-systemiteminfo/
https://foro.101level.com/desarrollo-y-pruebas-usuarios/(guia)-agregar-custom-item-lub/


Cualquier info que necesiten no duden en pedir plz necesito su ayuda  :Smiley-26:
« última modificación: 25 de Abril de 2018, 19:50 por Angeluz »


Desconectado -Elysium

  • *
  • 156
  • 4
  • Actividad:
    0%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #1 en: 25 de Abril de 2018, 20:57 »
Hola, la razón de por qué no se muestran es por que colocaste Naranja_Feather_Beret siendo que anteriormente el sprite se llama Naranja_FB en el accname.lua y accesoryid.lua

Desconectado Angeluz

  • *
  • 13
  • 0
  • Actividad:
    10%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #2 en: 25 de Abril de 2018, 22:50 »
Hola, la razón de por qué no se muestran es por que colocaste Naranja_Feather_Beret siendo que anteriormente el sprite se llama Naranja_FB en el accname.lua y accesoryid.lua

Gracias por responder Elysium, pero tu dices que los accname y accessoryid deberian quedar asi?





Porque tampoco me resulta  :Smiley-97:

Desconectado -Elysium

  • *
  • 156
  • 4
  • Actividad:
    0%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #3 en: 26 de Abril de 2018, 01:25 »
Cómo lo tienes en tu item_db? podrías colocar la línea del Feather Beret que no se muestra?


Desconectado Angeluz

  • *
  • 13
  • 0
  • Actividad:
    10%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #4 en: 26 de Abril de 2018, 02:27 »
Lo siento, en el post principal paso muy piola la foto, lo subo como codigo.

Código: [Seleccionar]
40010,Feather_Beret_N,Feather Beret Naranja,4,30000,,600,,1,,0,0xFFFFFFFE,63,2,256,,0,1,1800,{ bonus bMdef,1; bonus2 bSubRace,RC_DemiHuman,10; bonus2 bSubRace,RC_Player,10; },{},{}


EDIT: Esto no pasa solo con este item sino que con todos los custom
« última modificación: 26 de Abril de 2018, 03:52 por Angeluz »

Desconectado Tauro

  • *
  • 101
  • 0
  • Actividad:
    0%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #5 en: 26 de Abril de 2018, 08:30 »
Bueno haciendo una revisión rápida te esta faltando agregar los sprite de como se vera el item dentro del inventario y en el suelo, si no los colocas dependiendo la versión el item no se ve o sale como manzana. Se agregan en la carpeta arriba de donde colocaste los sprite de hombre y mujer. Lamento no dar mejor info justo hiba a dormir pero si no te sirve avisame y mañana te respondo.

Lo otro en tu item_db el primer nombre debe ser el mismo que los sprite 40010,Naranja_FB,aca es el nombre costume

Todos los .lua deben llevar el nombre original del sprite como ya dijieron arriba y para que el item tenga el nombre costume debes editarlo en System/iteminfo.lua identifiedDisplayName = Feather Beather Naranja
« última modificación: 26 de Abril de 2018, 08:36 por Tauro »


Desconectado Angeluz

  • *
  • 13
  • 0
  • Actividad:
    10%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #6 en: 26 de Abril de 2018, 16:13 »
Bueno haciendo una revisión rápida te esta faltando agregar los sprite de como se vera el item dentro del inventario y en el suelo, si no los colocas dependiendo la versión el item no se ve o sale como manzana. Se agregan en la carpeta arriba de donde colocaste los sprite de hombre y mujer. Lamento no dar mejor info justo hiba a dormir pero si no te sirve avisame y mañana te respondo.

Lo otro en tu item_db el primer nombre debe ser el mismo que los sprite 40010,Naranja_FB,aca es el nombre costume

Todos los .lua deben llevar el nombre original del sprite como ya dijieron arriba y para que el item tenga el nombre costume debes editarlo en System/iteminfo.lua identifiedDisplayName = Feather Beather Naranja

Gracias por responder, hice las modificaciones que me sugeriste coloque en el db lo siguiente

Código: [Seleccionar]
40010,Naranja_FB,Feather Beret Naranja,4,30000,,600,,1,,0,0xFFFFFFFE,63,2,256,,0,1,1800,{ bonus bMdef,1; bonus2 bSubRace,RC_DemiHuman,10; bonus2 bSubRace,RC_Player,10; },{},{}

Luego aplique el reloaditemdb, y sigue sin aparecer (manteniendo los cambios sugeridos por -Elysium)

Los de dentro del inventario y cuando se encuentra en el suelo, si no me equivoco son los que van en la carpeta texture/À¯ÀúÀÎÅÍÆäÀ̽º/item y Collection, que estan las fotos en el primer post o no?


« última modificación: 26 de Abril de 2018, 18:59 por Angeluz »

Desconectado Zutcer

  • *
  • 167
  • 1
  • Actividad:
    0%
  • Sexo: Masculino
  • How know the secrets tomorrow wild hold


Desconectado Angeluz

  • *
  • 13
  • 0
  • Actividad:
    10%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #8 en: 26 de Abril de 2018, 18:57 »
https://github.com/rathena/rathena/wiki/Custom_Items Lee

No sabia que podia adjuntar de otras paginas, pero si habia revisado ese link, de hecho de ahi saque el repositorio para los archivos lua https://github.com/zackdreaver/ROenglishRE



Bueno haciendo una revisión rápida te esta faltando agregar los sprite de como se vera el item dentro del inventario y en el suelo, si no los colocas dependiendo la versión el item no se ve o sale como manzana. Se agregan en la carpeta arriba de donde colocaste los sprite de hombre y mujer. Lamento no dar mejor info justo hiba a dormir pero si no te sirve avisame y mañana te respondo.

Lo otro en tu item_db el primer nombre debe ser el mismo que los sprite 40010,Naranja_FB,aca es el nombre costume

Todos los .lua deben llevar el nombre original del sprite como ya dijieron arriba y para que el item tenga el nombre costume debes editarlo en System/iteminfo.lua identifiedDisplayName = Feather Beather Naranja

Ahora entiendo tu punto del sprite para el inventario y el drop, y no habia agregado esa ss pero si estan los archivos donde corresponde.



Desconectado Tauro

  • *
  • 101
  • 0
  • Actividad:
    0%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #9 en: 28 de Abril de 2018, 18:23 »
Podrías re-subir todos los archivos modificados, ya que actualmente es imposible saber que te falta, o tal vez sea algo sencillo como un punto y coma


Desconectado Angeluz

  • *
  • 13
  • 0
  • Actividad:
    10%
  • Sexo: Masculino
Re:[Ayuda] Problema con los lua y los lub al agregar custom item
« Respuesta #10 en: 29 de Abril de 2018, 01:36 »
Podrías re-subir todos los archivos modificados, ya que actualmente es imposible saber que te falta, o tal vez sea algo sencillo como un punto y coma

Okas aquí mismo los adjunto en un drive debido a que era muy pesado el iteminfo

https://drive.google.com/drive/folders/1UZT7Lt5v-IEsPq9aUzAfissElixj9sUh?usp=sharing

Si necesitas algun otro me avisas  :Smiley-01:

______________________________________________________________________

PD: Tengo la impresion de que no me está leyendo correctamente los lua del accname y el id, podria alguien facilitarme una guia para modificar correctamente en el exe?


« última modificación: 01 de Mayo de 2018, 06:49 por Angeluz »


 

Problema al agregar custom item ._.

Iniciado por ramm_stein

Respuestas: 11
Vistas: 1702
Último mensaje 21 de Diciembre de 2010, 02:58
por GMKira
Problema al agregar item custom

Iniciado por raprap

Respuestas: 12
Vistas: 565
Último mensaje 06 de Marzo de 2013, 22:24
por raprap
Ayuda problema implementando item custom en mi server

Iniciado por elgete

Respuestas: 0
Vistas: 216
Último mensaje 01 de Junio de 2015, 20:54
por elgete